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FORMA04 - Travaux pratiques de la formation 
« Utilisation avancée » : contact de Hertz

Résumé : 

Ce TP traite du contact de Hertz, un des rares cas non triviaux de contact pour lequel on dispose d'une solution
analytique.
Le modèle est constitué de deux demi-sphères que l'on vient mettre en contact l'une contre l'autre.
Ce test simple permettra d'illustrer la mise en données du contact,  les différentes manières de résoudre le
problème et enfin les outils à disposition pour post-traiter un calcul de contact.
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1 Problème de référence

1.1 Géométrie

Le modèle est constitué de deux demi-sphères. On choisit de traiter le problème en axisymétrique, on
ne modélisera donc que des quarts de disque. Les données géométriques sont les suivantes :

• Rayon des sphères : R=50mm  

 

1.2 Propriétés des matériaux

Le matériau est élastique linéaire :
• Module d'Young : E=20000MPa
• Coefficient de Poisson : =0.3
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1.3 Conditions aux limites et chargements

• Déplacement suivant DX  bloqué sur l'axe A1A2  (cette condition est implicite en axisymétrique,
on l'impose néanmoins pour les points qui ne seraient pas parfaitement sur l'axe)

• Déplacement suivant DY  imposé : 
2mm  sur A1B1
−2mm  sur A2B2
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2 Solution de référence

2.1 Méthode de calcul

En 1881, Hertz a établi sous certaines hypothèses une solution au problème qui porte son nom[1].
Ainsi en supposant un contact sans frottement et pour lequel la demi-largeur de contact  a est très
petite devant le rayon des sphères R (a≪R), la pression de contact aux points C1  et C2  vaut [2] : 

P0=−
E

1−
2
  2hR  éq 2.1-1

où h correspond à l'écrasement imposé, qui vaut ici 4mm .

La demi-largeur de contact a s'exprime en fonction de l'écrasement imposé et du rayon des sphères :

a= Rh2  éq 2.1-2

La surface de contact est un disque de rayon  a, la distribution de pression en fonction du rayon  r
dans cette zone est la suivante :

Si ra alors P r =P01− ra 
2

éq 2.1-3

2.2 Grandeurs et résultats de référence

On comparera la pression obtenue au centre de la zone de contact et la demi-largeur de contact à la
solution analytique ci-dessus.

2.3 Incertitudes sur la solution

Aucune (sous les hypothèses données ci-dessus).

2.4 Références

Table des Matières
1: HERTZ H, Über die Berührung fester elastischer Körper, 1881
2: DUMONT G, La méthode des contraintes actives appliquée au contact unilatéral, 1993
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3 Modélisation A

3.1 Mise en œuvre du TP

3.1.1 Géométrie

Bien lire l'énoncé en entier avant de commencer

La géométrie est réalisée avec la plate-forme Salome-Meca, module Geometry. 

L'outil « Sketcher » (Menu New Entity → Basic → 2D Sketch) permet de construire le contour
du disque supérieur : A2 , B2 , D 2  et C 2  . L'arc de cercle est fait en 2 fois afin que Le point D 2
soit créé lors de la construction du contour. Pour B2D 2 , on donne le rayon à 50 et angle à -45° en
utilisant Direction et Perpendicular, et pour D 2C 2 , on  donne le rayon à -50 et angle à 45° en
utilisant Direction et Tangent. 

On peut ensuite construire une face à partir de ce contour (Menu New Entity → Build → Face). 

Par symétrie,  on peut générer  la deuxième sphère (Menu  Operations  → Transformation  →
Mirror Image) en choisissant l’axe X pour réaliser la symétrie. 

Il rest e à assembler les deux sphères p our ne constituer qu'un seul objet GEOM (Menu New Entity
→ Build → Compound ) . Attention : Dans cet objet, il y a toujours deux points, C1  et  C2  , qui
superposent. Au contraire, les deux points se fusionnent si l’opération est Partition , 

Enfin il faut créer des groupes sur cette géométrie (avec les noms suggérés dans la figure ci-dessus)
(Menu New Entity → Group → Create Group). On attire l'attention sur le fait que les groupes
sont créés en dernier . 

• Créer les groupes pour les surfaces des demi-sphères SPHHAU  et SPHBAS  
• Afin de créer d es groupes pour les point superposés C1  et C 2  , on utilise la fonctionnalité

permettant  de sélectionner un sous élément  d'une entité  GEOM  :  coche r «  Only Sub-
shapes of the Second Shape  », puis pour  C2  par exemple, sélectionner comme « 
Second Shape  » la demi-sphère supérieure dans l'arbre des objets, et seulement s es points
sont soulignés . 

• Créer les groupes pour l'application des conditions aux limites : le long d e l'axe d'axisymétrie (
A1A2  ) et sur les parties supérieures et inférieures des demi-sphères ( A1B1  et A2B2  ). 

• Pour  la  modélisation  du  contact,  on  aura  besoin  de  groupes  de  mailles  représentant  les
surfaces potentielles de contact : créer les groupes CONT 1  et CONT 2  . 

3.1.2 Maillage

On utilise  le  module  Mesh.  Le maillage  est  défini  par  le  menu  Mesh →  Create Mesh avec  la
géométrie à mailler. Le maillage sera réalisé en triangles, et on utilisera les hypothèses de maillage
automatique  « Assign a set of hypotheses  → 2D: Automatic Triangulation »  en
choisissant une longueur maximum de 2mm. 

On calcule le maillage  (Menu Mesh → Compute ).  On obtient alors un maillage contenant environ
3000 triangles et 1500 nœuds.

On importera ensuite les groupes à partir de la géométrie (Menu  Mesh → Create Groups from
Geometry). 

On importera le maillage au format MED. 
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Illustration 3.1: Maillage
obtenu pour la modélisation A  

 
3.1.3 Fichier de commandes

On utilise le module AsterStudy. Puis en colonne gauche, cliquer sur l'onglet Case View . 
On définit le fichier de commandes du cas de calcul. (cliquer à droite à CurrentCase et choisir Add
Stage). 
Nota : Pour ajouter des commandes : Menu Commands → Show All . 

En utilisant la commande STAT_NON_LINE , construire le fichier de commandes relatif au cas-
test en ne prenant pas le contact en compte dans un premier temps. 

• Que constate-t-on sur la convergence ? Que faudrait-il faire pour converger ? 
Indice : comment le critère de convergence par défaut est-il construit ?

  
Aide pour co nstruire le fichier de commandes : 

◦ Lire le maillage au format MED : Commande LIRE_MAILLAGE . 
◦ Définir le matériau : Commande DEFI_MATERIAU. 
◦ Affecter le matériau à tous les éléments  : Commande  AFFE_MATERIAU. 
◦ Définir les éléments finis utilisés : Commande AFFE_MODELE pour affecter le phénomène

MECANIQUE et la modélisation AXIS. 
◦ Affecter les  conditions  aux  limites  /  chargements  mécaniques :  AFFE_CHAR_MECA /

DDL_IMPO  pour  la  symétrie  axiale  et  les  déplacements  imposés  unitaires  que  l'on
multipliera ensuite par une fonction rampe avec le temps. 

◦ D éfinir  la  rampe  de  chargement  (déplacement  imposé) avec  la  commande
DEFI_FONCTION . Par exemple, la fonction varie entre (0.,0.)  et (2., 2.)  . 

◦ Créer  la  discrétisation  temporelle  à  l'aide  des  commandes DEFI_LIST_REEL. Par
exemple, 20 pas de 0s à 2s. 

◦ Résoudre le problème avec la c ommande  STAT_NON_LINE . On met COMPORTEMENT /
RELATION= ' ELAS ' , la liste d'instant définie précédemment dans  INCREMENT ,  les
matériaux  dans  CHAM_MATER ,  MODELE et également  les  conditions  aux  limites  et  le
chargement ( CHARGE + FONC_MULT ) dans EXCIT . 

Question bonus : combien y-a-t-il de mouvements de corps rigide en modélisation axisymétrique ?
Rappel : un mouvement de corps rigide est un mouvement à déformation nulle.

Ajouter  la  définition du contact :  orienter  les surfaces,  définir  la  charge de contact avec la
commande DEFI_CONTACT et adapter les options du solveur non linéaire. 
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Une alarme apparaît lors du calcul avec contact. On conservera la méthode de contact par défaut
dans un premier temps (FORMULATION='DISCRETE' et 'ALGO_CONT='CONTRAINTE').

◦ Orienter  la  normale  du  maillage  sur  les  contacts  :  Commande  MODI_MAILLAGE /
ORIE_PEAU_2D en utilisant les groupes  CONT1 et CONT2. On garde le même nom du
maillage en utilisant reuse. 

◦ Définir le contact : Commande DEFI_CONTACT. On conservera la méthode de contact par
défaut  dans  un  premier  temps  (FORMULATION='DISCRETE' et
'ALGO_CONT='CONTRAINTE'). On affecte les groupes  CONT1 et  CONT2 au couple des
zones de contact (maître et esclave).

◦ Adapter l’option de contact dans STAT_NON_LINE.

3.1.4 Pression de Hertz

Application numérique : calculer à la main avec les données du problème, la valeur de la pression de
Hertz et de la demi-largeur de contact (voir le chapitre 2). Les comparer aux valeurs obtenues par le
calcul.

Que constate-t-on ? Pourquoi cet écart ?

Remarque : on prendra en première approximation la composante SIYY  du champ SIEF_NOEU
(calculé avec la commande CALC_CHAMP / CONTRAINTE) comme pression de contact

Tracer la pression de contact en fonction du rayon dans la zone de contact, la comparer à la solution
analytique.

• C alcule r l e champ des contraintes par éléments aux nœuds ( SIEF_NOEU ) : commande
CALC_CHAMP / CONTRAINTE. 

• Créer un groupe de nœuds avec une abscisse curviligne orientée : commande DEFI_GROUP .
On gardera le même nom de maillage avec reuse. On utilisera l’option  CREA_GROUP_NO /
OPTION='NOEUD_ORDO' en donnant le groupe de maille ( CONT 1  ) et le point de départ (

C1  ). 
• Extraire  dans une table  la  composante  SIYY  du champ  SIEF_NOEU au dernier  instant :

commande  POST_RELEVE_T .  On  précisera  le  nom du  groupe des  nœuds,  le  instant,  le
champ et sa composante en utilisant l’opération EXTRACTION . 

• Créer  la  fonction  σYY= f (x )   :  commande  RECU_FONCTION .  On  définira  l’abscisse

curviligne ( ABSC_CURV ) comme PARA_X et SIYY comme PARA_Y . 
• Construire la solution analytique :

◦ C alculer la pression aux points C1  et C 2  , P0  et la demi-largeur de contact a 
◦ Créer  la  formule  analytique : commande  FORMULE.  Elle  dépend  de  la  coordonnée

curviligne x  (NOM_PARA='x' / VALE='P0*sqrt(1.-x*x/a/a)'). 
◦ Créer  une  liste  de s  valeurs réel le s  de  x   :  Commande  DEFI_LIST_REEL .  Par

exemple, 100 valeurs de 0 à 10mm. 
◦ Interpolation de la formule à partir de la liste de x    : commande CALC_FONC_INTERP . 

• Imprimer les deux fonctions au format XMGRACE par la commande IMPR_FONCTION . 

3.1.5 Contrainte de Von Mises

Afficher la contrainte de Von Mises sur la configuration déformée avec Salomé. Comment varie cette
contrainte dans la sphère ? Où se situe le maximum ?

On  affichera  la  composante  VMIS_SG du  champ  des  contraintes  équivalentes  SIEQ_NOEU
calculé avec la commande CALC_CHAMP / CRITERES.
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On  peut  imprimer  les  résultats  au  format  MED à  l’aide  de  commande  IMPR_RESU afin  de
visualiser le champ des contraintes dans Results ou dans Paravis et la position du maximum
(menu Edit → Find Data).

3.2 Grandeurs testées et résultats

Identification Type de référence Valeur de
référence

Tolérance

  yy  point C1  'ANALYTIQUE'  −2798,3Mpa  1,0%
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4 Modélisation B

On repartira de la modélisation A. Le maillage est le même que celui de la modélisation A mais il est
passé en quadratique.

4.1 Mise en œuvre du TP

4.1.1 Formulation continue

Convertir  le  maillage  de  la  modélisation  A en  maillage  quadratique  dans  le  module  Mesh (Menu
Modification → Convert to/from quadratic)

Afin de profiter pleinement des éléments quadratiques et d'obtenir un profil de pression lisse, il
est important de placer les nœuds milieux sur la géométrie lors de la conversion (cocher pour
cela la case « Medium nodes on geometry » lors de la conversion).

Changer de méthode de contact  et  utiliser la formulation  'CONTINUE'.  Observer la pression de
contact obtenue à l'aide du degré de liberté LAGS_C du champ DEPL. Comparer avec la méthode
de contact par défaut. Que constate-t-on ? Laquelle des méthodes fournit la meilleure approximation ?

Pour obtenir un profil de pression correct, il faut utiliser un schéma d'intégration des termes de
contact aux points de Gauss (INTEGRATION='GAUSS' dans la commande DEFI_CONTACT /
ZONE).

Afin de supprimer l'alarme qui apparaît avec les réglages par défaut, il est nécessaire d'imposer
REAC_ITER=1 sous  le  mot-clé  facteur  NEWTON de  la  commande  STAT_NON_LINE  (en
formulation continue, la matrice tangente est forcément reconstruite à chaque itération).

4.2 Grandeurs testées et résultats

Identification Type de référence Valeur de
référence

Tolérance

DEPL  LAGSC  point C1  'ANALYTIQUE'  −2798,3Mpa  3,0%
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5 Modélisation C

Dans cette modélisation, on réalise un maillage en quadrangles, avec un raffinement à proximité de la
zone de contact.

5.1 Mise en œuvre du TP

5.1.1 Réalisation de la géométrie

Dans  cette  modélisation,  on  doit  partitionner  la  géométrie  de  manière  à  pouvoir  la  mailler  en
quadrangles. 

Dans le module GEOM, une illustration de la partition possible est donnée dans la figure 5.1 :
• Prendre la face SPHHAU  et expliciter tous ses points (menu New Entity → Explode :

Vertex), puis on obtient les 4 points A2 , B2 , C 2  et D 2
• Créer l es points M  , N  et P  afin de générer les lignes de partition en rouge (menu New

Entity → Basic → Point ) : (0,25,0)  , (25,25,0)  et (25,50,0)  
• Générer les lignes de partition ( menu New Entity → Basic → Line ) 
• Partitionner SPHHAU  avec les lignes ci-dessus (Menu Operations → Partition ). 
• Par  symétrie,  on  peut  générer  une  nouvelle  face  inférieure (Menu  Operations  →

Transformation → Mirror I mage ) en choisi ssant l’axe X pour réaliser la symétrie 
• Il  reste à assembler les deux nouvelles sphères pour ne constituer qu'un seul objet  GEOM

(Menu New Entity → Build → Compound ) . 
• Définir tous les groupes comme dans la modélisation A, dont on aura besoin pour affecter les

conditions  aux  limites  et  les  chargements  (menu  New Entity → Groupe → Create
Groupe ) 

Illustration 5.1: Partition du disque supérieur  

5.1.2 Réalisation du maillage

Pour le  maillage,  on choisit  de raffiner  autour  de la  zone de contact  en utilisant  une progression
géométrique  sur  la  circonférence  et  sur  le  rayon.  Il  peut  être  nécessaire  de  réorienter  certains
segments dans le module Mesh :

• L e maillage est défini par le m enu Mesh → Create Mesh avec la géométrie à mailler. Le
maillage sera réalisé en triangles, et o n utilisera les hypothèses de maillage automatique « 
Assign a set of hypotheses  → 2D: Automatic Qua drangulation   »  en
choisissant le nombre des segments 15 . On c alcul e le maillage (Menu Mesh → Compute ) . 
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• On définit le sous-maillage (Menu Mesh → Creat Sub-mesh ) avec les groupes CONT 1  et

CONT 2 . Il est réalisé à l’aide de l’algorithme Wire Discretisation, l’hypothèse Start
and End Length (par exemple, 0.2mm et 2.0mm) et l’hypothèse avancée  Propagation
of Node Distribution on Opposite Edges.  On  obtient  alors  un maillage  linéaire
contenant environ 3500 quadrangles et 4000 nœuds. 

• P asser le maillage de linéaire à quadratique : «  Modification -> Convert to/from
quadratic  ». 

• On importera ensuite les groupes à partir de la géométrie (Menu  Mesh → Create Groups
from Geometry). 

Illustration 5.2: Maillage
en quadrangles obtenu
pour la modélisation C  

 

5.2 Grandeurs testées et résultats

Identification Type de référence Valeur de
référence

Tolérance

  yy  point C1  'ANALYTIQUE'  −2798,3Mpa  5,0%
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